Page 1 of 2 12 LastLast
Results 1 to 20 of 38

Thread: AVCMS Patch 1.0.4 with Images Beta

  1. #1
    AV Scripts Founder
    Join Date
    Oct 2006
    Location
    England
    Posts
    8,680

    Default AVCMS Patch 1.0.4 with Images Beta

    Today's update features bug-fixes and a whole new content-type in beta.

    The change list:


    • Added images beta to the core AVCMS script
    • Add alt attributes to wallpaper images & thumbnails
    • Fix game tag URL’s
    • Fix weird ordering of content on tags pages
    • Add option for 6 column modules
    • Template style updates
    • Make username’s smaller in profiles on mobile devices
    • Fix game points being awarded after 20 minutes instead of 2
    • Add submitter information to the play game page
    • Fix issues with duplicate tags when two tags exist with different capitalisation
    • Improved sizing of famobi games
    • Corrected some default wallpaper resolutions


    Images Beta

    AVCMS a new content type, images. You can create pages with a single image on or add multiple images to one page. You can then choose to display them as a list of images or as a gallery. You can bulk import images just like wallpapers and users can submit multiple images at once. Image Site Script will later be released as a separate product.
    Wherever possible, please use the forum to ask for support rather than sending me a PM
    I help where I can with code changes/modification but overall: if the script doesn't do something you want it to do, please suggest it for a future update.

  2. #2
    License owner
    Join Date
    Mar 2011
    Posts
    430

    Default

    Great update! Will videos be included in the future? If so is there an eta?

    Thanks!

  3. #3
    License owner
    Join Date
    Mar 2012
    Posts
    165

    Default

    The new content type, images - need translation?
    AVCMS Tapety Na Pulpit , my responsive ;-) AVS FREE COMPUTER GAMES

  4. #4
    License owner
    Join Date
    Aug 2010
    Posts
    1

    Default

    Error 404 Not Found on - Arcade profile -> All Liked Games

  5. #5
    License owner
    Join Date
    Jan 2012
    Posts
    259

    Default

    is it me or the themes ar broken now?

  6. #6
    AV Scripts Founder
    Join Date
    Oct 2006
    Location
    England
    Posts
    8,680

    Default

    Quote Originally Posted by mokshalstudios View Post
    Great update! Will videos be included in the future? If so is there an eta?

    Thanks!
    At some point I hope to do videos, but I don't know when.

    Quote Originally Posted by lkow77 View Post
    The new content type, images - need translation?
    Yes they will, I'll add the translations soon.

    Quote Originally Posted by zappin View Post
    Error 404 Not Found on - Arcade profile -> All Liked Games
    Thanks for the report. I've updated the zip files with a fix for this, you can update by downloading the zip again from the customer area and just uploading the src/AVCMS/Bundles/Games folder.

    Quote Originally Posted by kingkill View Post
    is it me or the themes ar broken now?
    How are they broken for you?
    Wherever possible, please use the forum to ask for support rather than sending me a PM
    I help where I can with code changes/modification but overall: if the script doesn't do something you want it to do, please suggest it for a future update.

  7. #7
    License owner
    Join Date
    Feb 2012
    Location
    Brasil
    Posts
    240

    Default

    Error 404 Not Found on - Arcade profile -> All Liked Wallpapers

    Edit:

    Fixed.


    I did the same thing, but with the Wallpapers folder

    Quote Originally Posted by zappin View Post
    Error 404 Not Found on - Arcade profile -> All Liked Games

    Quote Originally Posted by Andy View Post
    Thanks for the report. I've updated the zip files with a fix for this, you can update by downloading the zip again from the customer area and just uploading the src/AVCMS/Bundles/Games folder.
    Last edited by Sett; 06-27-2015 at 01:23 PM. Reason: Fixed

    Many fun games : Games da Hora

  8. #8
    License owner
    Join Date
    Sep 2012
    Location
    California USA
    Posts
    381

    Default

    @Andy
    I only have this problem which I am trying to fix...


    Catchable fatal error: Argument 2 passed to Pixie\QueryBuilder\QueryBuilderHandler::whereIn() must be of the type array, null given, called in /home/(Username)/public_html/src/AVCMS/Bundles/Games/Model/GameFeedCategories.php on line 35 and defined in /home/(username)/public_html/vendor/usmanhalalit/pixie/src/Pixie/QueryBuilder/QueryBuilderHandler.php on line 567

    So I think I am going to try to re-upload the vendor folder and see if that helps and take a look at game Module categories PHP on line
    then the other file and see if I can do something with them.. My game feeds are there I just cannot update the feed...

    This is the difference in the lines and since I am not a developer I would rather not tackle this alone:

    /home/(Username)/public_html/src/AVCMS/Bundles/Games/Model/GameFeedCategories.php on line 35:
    Code:
     $result = $this->query()->whereIn('keyword', $keywords)->select(['category_id'])->first(\PDO::FETCH_ASSOC;)
    /home/(username)/public_html/vendor/usmanhalalit/pixie/src/Pixie/QueryBuilder/QueryBuilderHandler.php on line 567
    Code:
     public function whereIn($key, array $values)
    Now I don't usually use the feeds and find games, however I like things to be kept updated because I do occasionally use it..LOL

    OMG look at the errors I downloaded I guess I have to reinstall everything??

    error_log.zip

    * Update I am uninstalling all the software and going to use the lower version. The reason is I deleted all the software and I uploaded a fresh copy of 1.0.4 and that is where the error is... so Here I go again .,, delete and install ..

    Thanks
    Last edited by Starnova; 07-03-2015 at 12:09 AM.
    Rose Entertainment
    Your Source for Family Fun
    http://www.roseweb.net

  9. #9
    License owner
    Join Date
    Jun 2010
    Location
    NC, USA
    Posts
    488

    Default

    Nice Update! But on a side note I noticed that users can register through Facebook connect even when maintenance is enabled which I don't think should be allowed.
    RetroSprite - Currently Working On A Resurrection
    Managed Cloud VPS Hosting
    - Shared SSD Cloud Hosting

  10. #10
    License owner
    Join Date
    Jun 2010
    Location
    NC, USA
    Posts
    488

    Default

    I just started messing with the new Image section and I've noticed a few errors. The first is the Images menu item, it doesn't link to a page but links to /# which I guess is supposed to be /images. Another is a error when trying to download a image. It says Collection not downloadable.
    RetroSprite - Currently Working On A Resurrection
    Managed Cloud VPS Hosting
    - Shared SSD Cloud Hosting

  11. #11
    AV Scripts Founder
    Join Date
    Oct 2006
    Location
    England
    Posts
    8,680

    Default

    The images menu item is a drop-down for categories but there are none by default, so when you add a category it will display correctly.

    I'm aware of the download collection bug and will fix, thanks
    Wherever possible, please use the forum to ask for support rather than sending me a PM
    I help where I can with code changes/modification but overall: if the script doesn't do something you want it to do, please suggest it for a future update.

  12. #12
    License owner
    Join Date
    Jun 2010
    Location
    NC, USA
    Posts
    488

    Default

    Quote Originally Posted by Andy View Post
    The images menu item is a drop-down for categories but there are none by default, so when you add a category it will display correctly.

    I'm aware of the download collection bug and will fix, thanks
    Ok I was wondering why the Image menu item did nothing lol. But I noticed another bug when editing a Image Collection the drag feature does not seem to work for me so I can't rearrange the gallery.
    RetroSprite - Currently Working On A Resurrection
    Managed Cloud VPS Hosting
    - Shared SSD Cloud Hosting

  13. #13
    License owner
    Join Date
    Jun 2010
    Location
    NC, USA
    Posts
    488

    Default

    Another note why is there a Image Collection Sidebar module when the Image Collection pages use the site wide Siderbar module?
    RetroSprite - Currently Working On A Resurrection
    Managed Cloud VPS Hosting
    - Shared SSD Cloud Hosting

  14. #14
    License owner
    Join Date
    Jun 2010
    Location
    NC, USA
    Posts
    488

    Default

    Of course I have found something else to nitpick . In the Games and Wallpapers module the Order option is after the Filter option but in the Images module the Order option is at the bottom of the settings instead of being after the Filter option like the other modules. Keeping these module settings in unison would be nice.
    RetroSprite - Currently Working On A Resurrection
    Managed Cloud VPS Hosting
    - Shared SSD Cloud Hosting

  15. #15
    License owner
    Join Date
    Jun 2010
    Location
    NC, USA
    Posts
    488

    Default

    I tried adding a Liked Images module as a list panel to the User Profile Sidebar but none of the liked images showed up nor did the text that's supposed to say the user didn't have any liked images.

    RetroSprite - Currently Working On A Resurrection
    Managed Cloud VPS Hosting
    - Shared SSD Cloud Hosting

  16. #16
    License owner
    Join Date
    Sep 2012
    Location
    California USA
    Posts
    381

    Default

    Well I fixed my problem I am glad to say. All is good now
    Last edited by Starnova; 07-04-2015 at 12:15 AM.
    Rose Entertainment
    Your Source for Family Fun
    http://www.roseweb.net

  17. #17
    License owner
    Join Date
    Jun 2010
    Location
    NC, USA
    Posts
    488

    Default

    Another bug I found is with the Image Tag module. It says 'No tags' even though I already have a few images with tags.

    Something else that isn't really a bug but when ever I click add image collection after just adding a image, that previous image shows up until I upload a new image. It makes me feel like I'm still editing the previous image instead of adding a new one.

    I just found a weird random bug in the admin panel. When going down the list of images in the admin panel sometimes images are shown multiple times when the next page of images loads. I can't figure out why it happens because sometimes there are duplicates and sometimes there aren't.
    Last edited by retrosprite; 07-04-2015 at 05:54 PM.
    RetroSprite - Currently Working On A Resurrection
    Managed Cloud VPS Hosting
    - Shared SSD Cloud Hosting

  18. #18
    License owner
    Join Date
    Jun 2010
    Location
    NC, USA
    Posts
    488

    Default

    The URL Slug has a bug. Normally after entering the name of the image the URL Slug is automatically filled in. But after the first upload every subsequent Image Collection you add it does not automatically fill in unless I click the Slug refresh button, I'm using Firefox.
    RetroSprite - Currently Working On A Resurrection
    Managed Cloud VPS Hosting
    - Shared SSD Cloud Hosting

  19. #19
    AV Scripts Founder
    Join Date
    Oct 2006
    Location
    England
    Posts
    8,680

    Default

    Thanks for the bug reports I'll look into them.
    Wherever possible, please use the forum to ask for support rather than sending me a PM
    I help where I can with code changes/modification but overall: if the script doesn't do something you want it to do, please suggest it for a future update.

  20. #20
    License owner
    Join Date
    Jun 2011
    Posts
    27

    Default

    I have previously updated 2 AV Arcade sites from 5.8 to 6.0.3 without any problems. Today I was trying to update another 5.8 site but was using the latest AV Arcade version 6.0.4 but was getting the following error messages both on Firefox and similar messages on Opera: The page isn't redirecting properly.

    I can do a fresh install without any problems. I was updating as follows:

    yoursite.com/upgrade/admin/ava-import

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •