PDA

View Full Version : AVArcade Pro Compatibility Checker



alexander
05-30-2010, 09:11 PM
I am still finding my way around PHP (and the rest) so I thought I might see if I could make a compatibility checker for AVArcade Pro (best idea I've had in a while - shows how vivid my imagination is). All it does at the moment is check whether your server's version of PHP is compatible, semi-compatible or not compatible with AVArcade Pro. I have used the information from the AVScripts FAQ.

All you need to do is upload this file to your server and then visit it.


<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<title>AV Arcade Pro Compatibility Checker</title>
<style type="text/css">
@charset "utf-8";

body {
background:#1469BE url(http://i50.tinypic.com/2i8bupy.jpg);
font-family:"Lucida Sans Unicode", "Lucida Grande", sans-serif;
}
.head {
width:880px;
margin:auto;
background-color: #BCE1FC;
padding:10px;
margin-top:100px;
}
.main {
width:880px;
margin:auto;
background-color:#FFF;
padding:10px;
}
.smallerlink {
text-align: center;
}
.smallerlink a {
font-size: 14px;
color: #039;
}
</style>
</head>
<body>
<div class="head">AV Arcade Pro Compatibility Checker</div>
<div class="main">
<?php
$phpVersion = phpVersion();

if ($phpVersion >= 5.2) {
echo '<b><font color="green">You version of PHP (',$phpVersion,') is compatible with AVArcade.</font></b>';
}
else if ($phpVersion <= 5.2 && $phpVersion >=5) {
echo '<b><font color="orange">You version of PHP (',$phpVersion,') is semi-compatible with AVArcade. You will be unable to use the Mochi game downloader.</font></b>';
}
else {
echo '<b><font color="red">Sorry, your version of PHP (',$phpVersion,') is not compatible with AVArcade.</font></b>';
}
?>
<div class="smallerlink"><p><a href="https://www.avscripts.net/store/order/index.php?task=product&product_id=1&category_id=1.1">To purchase AVArcade Pro, click here.</a>
<div class="smallerlink"><p><a href="http://www.ancgames.com">AVArcade Pro Compatibility Checker by Alexander</a></div></div>
</div>
</body>
</html>

Please give me feedback :)

Thanks,
Alex

Chuckun
05-30-2010, 09:55 PM
Nice idea dude :) I too lack imagination, which doesn't help when you're into programming xD

A lot of people would find this useful, so good job :D

belly59
05-31-2010, 11:20 AM
I like the idea. I think you have a good starting point for other things to be added to.

I think joomla has a similar system where it rates your servers compatability ... perhaps borrow a few of their ideas ...