PDA

View Full Version : php 5.3 problem for video script



okeyme
02-24-2016, 10:24 AM
my dedicated use php5.3 and video script want 5.4
and i cant change php version how i can install it

robbyq92
02-24-2016, 04:21 PM
i can help you, you need install php 5.4 and upgrade in your server.

What SO used? Ubuntu? Centos?

okeyme
02-25-2016, 09:41 AM
centos6 ispmanager 4 lite

okeyme
02-29-2016, 06:10 PM
new problem
Fatal error: Call to undefined function json_encode()

Andy
02-29-2016, 07:49 PM
That would suggest the JSON PHP extension is not installed. You will need to get that installed for a number of functions to work as it's a standard extension.

robbyq92
02-29-2016, 08:53 PM
new problem
Fatal error: Call to undefined function json_encode()


Try ssh


yum update “*php*”

pecl install json

cd /etc/php.d/

echo “extension=json.so” >> json.ini

service httpd restart

robbyq92
02-29-2016, 08:58 PM
if not yum install php-pecl-json

okeyme
03-01-2016, 10:37 AM
but this is opt php under /opt/php56
and json installed but give error

nano /opt/php56/etc/mods-available/json.ini
File: /opt/php56/etc/mods-available/json.ini

extension=json.so

okeyme
03-01-2016, 11:48 AM
ok problem fixed thanks