PDA

View Full Version : Videos for AVCMS beta



Andy
01-17-2016, 08:51 PM
Hi everyone,

Today I've added a beta version of the Videos bundle to the core AVCMS script. It focuses on embedding videos from other providers such as YouTube & Vimeo rather than processing video itself, so you save bandwidth and get easy access to millions of videos. You can also embed local videos as long as they are already in a web format like MP4.

The bundle has all the standard bundle features like submissions, tags, comments, like/dislike but also has a few special features for videos.

For example, to add a video all you need to do is paste the URL and AVCMS will automatically fill in the form with the title, description, duration & more. This initial beta version can automatically pull in the video details from Dailymotion, Funny Or Die, Metacafe, Vevo, Vimeo, Vine & YouTube. If you have any suggestions for other video sites, let me know.

In addition to automatically getting the video data from those sites, you can browse YouTube right from the admin panel. This allows you to quickly select and bulk-import videos from YouTube!

http://i.imgur.com/Sdv89vbl.png (http://drop.avscripts.net/1jlXz.png)

How to install & enable videos beta


Download the latest version of AVCMS from the customer area. The version number has not increased from 1.0.7, but the beta videos bundle has just been added today. You must own the full version of AVCMS, not a spin-off product like AV Arcade.
Upgrade your site by following the normal upgrade instructions
Enable the Videos bundle in the "Bundles" section of the admin panel
Click "Regenerate Assets" from the cog icon in the admin panel


Once installed and enabled, there won't be any modules on the homepage for things like "Newest Videos", but these can be added in the admin panel Modules section.

There are likely to be a few bugs as this is a beta, but the bundle should be perfectly safe to use on a live website. Translations and full support will come when the beta has ended.

I hope everyone likes the new features. As ever, there will be a stand-alone Video script launched when the bundle is out of beta.

Andy

iMage
01-18-2016, 04:46 AM
Looks awesome Andy

Jedimeister
01-18-2016, 03:42 PM
Great job, Thanks

YouTube videos work best ever.

iMage
01-19-2016, 03:56 PM
Embeds videos very well when adding manually. The import function isnt working for me for whatever reason, that its in beta i guess though

Jedimeister
01-19-2016, 05:05 PM
I have to say the import works very ut with me

iMage
01-19-2016, 05:48 PM
Wierd, dont know why its not working for me :/

Andy
01-19-2016, 06:54 PM
Do you get any error messages or anything like that? Could you send me the login details to your admin panel? It would be nice to take a look.

iMage
01-19-2016, 06:58 PM
I dont have any error messages Andy, it just doesnt do anything at all when using the import button. If you would like to register on my site (no email activation necessary) i can give you admin on my site

gamestimeline.com

Andy
01-19-2016, 07:15 PM
Thanks, I've registered on your site as "Andy".

iMage
01-19-2016, 07:15 PM
done Andy, thanks

Andy
01-19-2016, 07:33 PM
Ah, I needed to regenerate the assets and that's got it working.

I'll add that to the instructions.

Andy

iMage
01-19-2016, 07:35 PM
Oh ok, i dont know why i didnt think of that lol.. thanks for having a look Andy

Dakoom
01-20-2016, 02:35 PM
Great idea, Andy! Keep up the good work! :)

robbyq92
01-21-2016, 04:48 PM
awesome :)

retrosprite
01-22-2016, 08:49 PM
Wow I've been so busy I didn't even notice this news post until now... I'm going to try it out today. :cool:

retrosprite
01-23-2016, 12:16 AM
I didn't mean to overload the forum with a hundred posts so I combined them into one. :p Here is a link (https://www.retrosprite.com/videos) to my videos page if anyone wants to check it out before updating your own website with the videos beta.

*BUGS

*Categories can not be moved, they revert back to the same place on refresh.

*The Maximum User Submissions option does not work, users can submit an unlimited amount of videos regardless of this setting.

*Please change the YouTube embed url from "http://www.youtube.com/embed/" to "https://www.youtube.com/embed/". I can't play the embedded YouTube videos because they are blocked on my HTTPS website.
--Update: I was able to edit the youtube.twig file and do this myself.

*On the Video Submissions page the user field is blank, it was definitely submitted by a user and all of the dates submitted say 1969-12-31.

*The Credited User is not showing on the Video pages. ex- Submitted By: Username

*On the Import YouTube Videos page I searched a username and the users videos were repeated on a infinite amount of pages of the same videos which should have only been one page.

*Limit Video Plays option in the video settings does not work. I set it to 2 and could still view as many videos as I wanted.

*Adverts Before Videos does not work, the selected ad does not show up nor does the skip ad button show up.

*The volume icon seems to overlap the buttons on mobile:

Click For Image (http://i.imgur.com/RcA7iyj.png)

*I'm getting mixed content errors from the MP4 Player which might be the reason I get a error message on mobile chrome and it wouldn't play. The video played fine on desktop chrome, I'm not sure what can be done about the mixed content errors since there doesn't seem to be a https version of the links giving the error:

Click For Image (http://i.imgur.com/5Yur2UJ.png)

*If you click Like then Dislike it continues to add points to the user, on refresh the points show up unchanged. Shouldn't there be a limit to how much a user can change their like/dislike over and over again? I guess it's not hurting anything though.

Click For Image (http://i.imgur.com/mY2Qjbh.png)

--I just noticed a bug in the image above, it says I earned points for a comment when I clicked the like/dislike button... I actually couldn't get this comment message to appear again when clicking like/dislike, weird nonetheless.

*If you are adding or changing the title of a Game, Image, Video, or Wallpaper and it contains a slash(/) the URL Slug will not generate. It seems the user submitted videos had no problem with the URL Slug generating but when I went to change the title I couldn't figure out why a new URL Slug would not generate until I noticed erasing the slash made it generate again.

*Unchecking the "Show more button" option in a video module does not seem to work as the "All Featured Videos" button continues to show regardless.

*There are module positions in the admin panel for Play Video Sidebar and Image Collection Sidebar when neither of these module positions actually exist.

Feature Ideas:



We need the "Delete files when deleting wallpapers" option for Games, Images, and Videos.
Can you pull the tags from a YouTube video when automatically filling in the videos info?
I have a idea for the videos too which is GIF thumbnail previews. I think it would be cool when a user hovers over a video thumbnail it plays a preview GIF of the video. I don't know how difficult it would be to implement something like this that generates GIFs of videos so add it to the fantasy list lol.
Currently we have the option to show the publish date for Videos, Images, etc but what I would like is a option to show how long ago it was published like how YouTube says how long ago a video was added(ex: 2 years ago, 2 days ago, 2 hours ago) when browsing videos.
The Import YouTube Videos page has a option to only view HD videos, we need a SD/HD icon on all of the videos on this page so we can tell them apart without selecting this option.
It would be awesome if we could look at YouTube videos from specific users through the Import YouTube Videos page.
I don't like the way videos under a minute show up. For example a video with 28 seconds (00:28) shows up as simply 28 on the video instead of 00:28. In my opinion videos under a minute should show up with the two zeros in front, 00:28.

http://i.imgur.com/GYUjXYW.png

retrosprite
01-23-2016, 07:24 PM
Embeds videos very well when adding manually. The import function isnt working for me for whatever reason, that its in beta i guess though

The Import function is not working for me, I did regenerate the assets...

*Update

Actually disabling CloudFlare made the import function work... now I have to figure out why. :confused:

**Update

I had to clear my entire CloudFlare cache which made importing videos work but all of the other bugs I posted still exist.

Starnova
01-25-2016, 03:05 AM
Look at how many times you have please delete,,, You can edit and delete them yourself my friend,,, Anyhow Andy I just came by to say thank you for this nice addition,,the videos , For me all is working perfect...:D

retrosprite
01-25-2016, 04:28 AM
Look at how many times you have please delete,,, You can edit and delete them yourself my friend,,, Anyhow Andy I just came by to say thank you for this nice addition,,the videos , For me all is working perfect...:D

Thanks for the info I never knew I could... :eek:

retrosprite
01-25-2016, 11:13 PM
It would be nice if you could create a module that allows you to attach images, wallpapers, or videos to. For example on a game page we could attach a video/image from our website that's related to the game and the attached content shows up wherever we place the module. On a video page the module could be a spot to attach wallpapers or images related to the video. It basically just makes the different content types feel more integrated while showing users who like something more content they may also like.

Andy
01-26-2016, 07:12 PM
Thanks mycheatcentral, I'll get an update out with fixes soon.

retrosprite
01-28-2016, 12:39 AM
Minute durations show up like 04 instead of 04:00

http://i.imgur.com/KDfmuGH.png

It looks out of place next to the rest of the videos and actually shows up the same way short second duration videos appear which also look out of place.

retrosprite
01-28-2016, 03:53 PM
When it comes to features for a video script shouldn't some sort of age restriction be one, just a thought.

retrosprite
01-28-2016, 10:39 PM
After reviewing and clicking submit on a video submission the video still shows up on the submission list until refresh but clicking review again then submit will show a Save Error: Internal Server Error message.

retrosprite
01-31-2016, 02:40 AM
I just noticed the video duration for YouTube videos is acting weird. All of the video duration's are a second more than they should be. When the video plays the total duration on the player goes down by one second. Anyone else notice this?

*Update
Actually after downloading a video it seems the duration AVCMS grabs is correct it just so happens YouTubes HTML5 player is weird.

retrosprite
02-03-2016, 06:46 AM
I noticed in Firefox the local video player shows the first frame of the video behind the play button when you load the page but in Google Chrome it just shows a black screen behind the play button.

https://www.retrosprite.com/video/retrosprite-intro

retrosprite
02-04-2016, 10:30 AM
*Bug

I created a Video module in the User Profile Main module position and I have it set to filter user likes and order it by newest. But it ignores the order setting no matter what I set it to.

kenshin1
02-26-2016, 07:49 AM
Would like to have a way of changing/adding new video providers for submissions, currently it rejects anything from any place else other than the ones listed.

mafa
06-11-2016, 05:05 PM
Thanks Andy, I just joined the forum, I just installed your software and have not found any fault, it runs smoothly!

phatlocreal0
01-06-2017, 02:18 AM
look nice bro, keep moving up